Object Types definitions Extension

Hello everyone,

I have problems figuring out what the option “Use as Protocol” does and how it works.
I used the Fly Object Type for testing purpose, created an Object of this type in the Inventory but somehow I cannot add this protocol as a parent to my experimental step (as described in the documentation “How to use protocols in Experimental Steps”).
Any ideas what I did wrong?

I am using openBIS 20.10.5 as a multi-group instance.

Best regards,

Hi Julia.
Thank you for the message.
Please, follow the link to get info on how to add a parent to the experimental step.


Hi Rostyk,

Adding Parents and Children is not a problem.
I am wondering what the effect of enabling “Use as Protocol” is? I followed the instruction but it doesn´t seem to work as stated there?

Best regards,

Hi Julia,

Thank you for the update.
If a new Object type for a protocol is created (by an Instance admin), it is recommended to set the new Object type to Protocol in the Setting under Utilities section.

This is done to be able to create local copies of protocols from the Inventory inside an Experiment when writing an Experimental step.

Are you the user of the ETHZ Research Data Hub (central multi-group instance) or your run openBIS Node (private multi-group instance)?


Hi Rostyk,

thank your for your answer. Now everything is clear to me and working fine!
I was a bit confused by “to be able to use protocols from the inventory as templates” because there are actually templates in openBIS, while here it is used in the context of the local copy.
And the ‘Use as Protocol’ seems to work only in combination with ‘Show in drop downs’.

I am at the University of Osnabrueck, we run a private multi-group instance.

Best regards,

Hi Julia,
I am glad to hear you find my explanations helpful.
Feel free to contact us.

Wishing you a Happy Holiday Season.

Dear all,

it seems I have the same or similar question about protocols.
I tried to follow the instructions to create a collection of protocols, and first created a new protocol called EBSDSIM_PROTOCOL in the NGAdmin interface (see screenshot below), and then created the folders “Protocols” in Methods, and there a new collection “EBSD Simulation Protocol”
If I then go to Settings for this object and enable “use as protocol” and “show in main menu” as shown on the documentation for “Enable Protocols in Settings”, and then go to the collection I create a specific instance of this protocol.
However, If I go to an experiment and add a new experimental step, I can add a new instance of the general protocol by clicking Parents / General Protocol → Search.
(But this only seems to apply to general protocols, not specific ones?)

Do I then assume correctly, that my specific protocol would be added as a parent?
However, if I click “search any”, I am asked to choose from a template, but because in the settings as per the instructions on “Enable protocols in Settings” the item “show in drop-down” is not enabled it doesn’t show up here.
If I do enable “show in drop downs”, it does show up and I can add it as a parent.

I guess my questions can be summarised as follows:

  • The “General protocol” in the experimental step is (the name gives it away) just for General Protocols?
  • Specific protocols need to be added as a parent
  • we need to enable “show in drop-downs” to be able to find it as a parent?

Many thanks



Dear Ulrich,

here you can find the explanation on how to use protocols in Experimental steps: openBIS | How to use protocols in Experimental Steps

By default, the experimental step form only show the general protocol, because this is what comes pre-defined in the system. However, if you add your own protocol types, you can further customize the Experimental step form, as explained here: openBIS | Customise Parents and Children Sections in Object Forms
openBIS | Enable Protocols in Settings

I hope this helps,