Docker v20.10.5 - not ELN

Dear openBIS community,

Thank you for the new release. It has many features and improvements.

A “fresh” docker installation shows that both the core and the ELN-LIMS versions are 20.10.5. However, when binding to the volume where the previous docker image was used, admin version is 20.10.5, but the ELN-LIMS is still 20.10.4.

Thank you and best regards,

Dear Mariam,

you are observing a phenomenon that we’re already aware of, but ways to work around this have not been documented yet. The issue is that if you re-use an existing volume, which also contains the core-plugins/eln-lims sub-folder, openBIS will prevent upgrading the pre-existing plugin. The upgrade of eln-lims will only work, if you first stop OpenBIS, then remove the folder <openbis_state>/core-plugins/eln-lims, and then start OpenBIS again. In case you’ve made any customizations to the plugin, please take a backup and then apply them also to the new folder.


OpenRDM operations
Research IT Platforms
Scientific IT Services
ETH Zürich

Hi Richard,

Thank you very much for your clear, informative reply. Removing the eln-lims folder worked on the empty test instance, but on the other populated instance, the upgrade only worked when I removed the whole core-plugins folder. Now we are enjoying 20.10.5.

Thanks and best regards,
Scientific IT, Fraunhofer IFAM