we’re currently implementing (and revising) the metadata schema in openBIS.
As with anything like that, in hindsight it would be better to have named some properties better or some properties are similar enough to be merged into one, etc.
Since users have also already started to use the system, we reach the usual conundrum that it might be nicer to clean up some properties but we can’t really ask everyone to enter all data again and/or link them to their other records via parent/child relationships,e tc.
For example, an entity might be named “microscope” but it’s really an electron microscope.
I can change the description but not the “code”. Of course, I can create the next type as “LIGHT_MICROSCOPE” so, in practice, there isn’t really any confusion but it’s not nice…
(Or someone might have entered “Kamera” instead of “Camera” for a property type, etc)
It’s not a problem as such but, well, …